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About the Product 
The Datgel Rock Mechanics Tool gINT Add-In is designed to streamline the classification of material 
based on a user defined classification system with up to three parameters.  The tables and field names 
from the user’s database are used to configure the tool and the interpretation is then written back to the 
database. 

You need to complete the installation procedure (see Installation and Licensing on page 1) and activate 
(see Datgel Product Licensing System User Guide) before you can use the Rock Mechanics Tool. 

Support 

12 months support and maintenance is included with the license purchase.  For technical support 
please email support@datgel.com or call +61 2 8202 8600. 

System Requirements 

gINT 

The product runs optimally using gINT 8.2.003 or higher, however it will run using gINT 8.1 or higher. 

gINT Professional is recommended.  The product will run using gINT Logs, gINT Logs Plus, and gINT 
Professional.   

Hardware and Operating System 

Same system requirements as gINT 8.2, see: http://www.gintsoftware.com/products_requirements.html. 

Required Windows Components 

1. Windows Installer 3.1 

2. .NET 3.5 Framework SP1 

Conventions and typography used in this guide 

Note: Tips and additional Information to help you. 

> Used to indicate a series of menu commands. 

e.g. Select File > Open.  

| Used to indicate a gINT Application Group, Application, Table Group or Table , e.g. 
DATA DESIGN | Project Database 

Bold Text Items you must select, command buttons, or items in a list. 

e.g. Navigate to UTILITIES | Convert Projects (4
th

 tab). 

Italics Emphasis Use to emphasize the importance of a point such as parameters. 

e.g. Data Entry – Check Omit Must Save prompt when save is required 

CAPITALS Names of keys on the keyboard. for example, SHIFT, CTRL, or ALT. 

KEY+KEY Key combinations, for example CTRL+P, or ALT+F4. 

Code Snippet Indicates a code snippet within a paragraph 

Code sample Indicates a sample program codes inserted in user guide e.g. 

mailto:support@datgel.com
http://www.gintsoftware.com/products_requirements.html
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public override string ToString () 

File name or path Used for formatting file name and paths e.g. di_lib.glb or  

V:\10 gINT\Datgel Install Files\ 

Table_Name Database table name, e.g. POINT_TABLE. 

Field_Name Database field name; e.g. PointID 

Command line Command line, presented exactly as it must be entered e.g. 

cdir 
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1 Installation and Licensing 

1.1 Installation Overview 

There are five parts to the installation process: 

 Install DLL program 

 Merge gINT library objects 

 Merge gINT point table objects to your project file and your data template 

 Import example Material Classification Schemes to your database (optional) 

 Activate the product license 

The first three steps can be performed in any order and are described below. The activation procedure 
must be done last and is described in the Datgel Product Licensing System User Guide. 

1.2 Package Contents 

Your software purchase may have come with the following contents: 

 Applications CD which normally has the following folders:  
\gINT Files 

\Datgel Network License Server 

\Documentation 

\Installation files 

 A hardware license key 

1.3 Before Installation 

A few basic preparations can help ensure an effortless installation. 

 Make sure that the computer where you plan to install the program meets the minimum 
hardware and software requirements.  

 Connect your PC to Internet before installation (must have a working Internet connection).  

The Rock Mechanics Tool requires that the Microsoft .NET 3.5 framework SP1 is installed on 
the PC prior to the installation of the Tool.  If your PC does not have the .NET 3.5 framework 
SP1 installed, then it will be automatically downloaded and installed during the Tool installation 
process.  

 Log into the PC with Administrator privileges before starting installation. 

 It is recommended that you exit out of other applications that maybe running on your PC. 

 Close gINT before you start installation. 

 Keep the serial number and license number handy. 

1.4 Install DLL Programs  

1. If you received an installation CD, then insert the CD and browse to the folder  

\Installation Files 

2. Double click the file named Setup.exe 

3. Click Run to begin installation.  
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Follow the on screen instructions when installation begins: 

4. Click Next on the Welcome to the Datgel Rock Mechanics Tool Setup dialog. 

 

 

5. Scroll and carefully read the License Agreement, and choose option I Agree, and click Next. 

  

Alternatively choose I Do Not Agree and click Cancel if you disagree with the license 
agreement. The installation will stop and exit.  

6. On the Select Installation Folder dialog, either accept the default folder (recommended) or 
select Browse to specify the folder where you want to install the Rock Mechanics Tool Add-In. 

Leave Everyone bulleted to indicate that anyone logged onto the PC can use the Rock 
Mechanics Tool Add-In. 

Click Next when ready. 
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 OPTIONAL  Click on Disk Cost to view the disk space statistics. Click OK when done. 

  

7. Click Next to start installation. 

  

8. Observe the progress bar to monitor installation progress  
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9. Click Close when the Installation Complete dialog is displayed. 

  

1.5 Merge gINT Library Objects 

 IMPORTANT   In the trial version of the Rock Mechanics Tool gINT Add-In, the library will be locked and 

you cannot merge any gINT Library Objects into your Library file, or make changes to this Library file.  In this 
case, you have to use the locked library as-is.   

If you have purchased the Rock Mechanics Tool gINT Add-In, then you have full access to the library 
objects, and you may proceed with the following steps to merge the gINT Library components into your 
Library file.  

1. Make a backup copy of your existing library file. By default this is located at: 

C:\Program Files\gINT\libraries\ 

2. Start gINT and open the library and project file you wish to use with Datgel Rock Mechanics 

Tool gINT Add-In. 

The opened project and library files are displayed at the top of the gINT Window. 



 

 

Rock Mechanics Tool gINT Add-In –  Datgel 
User Guide 5 DRMT-UG-001 - 1.03- August 2009 
 

  

3. Select UTILITIES | Lib Merge/Copy. 

  

4. Check the bullet that reads Merge From. 

5. In the Source Library File pane, browse the installation CD for file  

Datgel Rock Mechanics Tool lib ##.glb where ## is the version number. 

6. Check the bullet that reads Select All. 

7. Check the bullet that reads Query On Overwrite. 

8. Click  button to move all tables from the Available Source Tables pane on the left to the 
Tables to Merge/Copy pane on the right side. 
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9. Click Execute. 

Take care to read the overwrite dialog and click Yes if you wish to overwrite the file, ELSE click 
No. 

  

This will merge in the lookup lists, Add-In menu item, and gINT Rules modules which are all 
related to the Tool. 

10. Click OK to finish the merge. 

  

1.6 Merge gINT Project Tables and Fields 

1. Make a backup copy of your existing project file. By default this is located at: 

C:\Program Files\gINT\projects\ 

2. Start gINT and open the library and project file you wish to use with Datgel Rock Mechanics 

Tool. 
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3. Select DATA DESIGN | Project Database. 

4. Select File > Open File > Current Project… to open your current project file. 

5. Select Tables > Import Multiple Tables... then browse the installation CD and select the file 
Rock Mechanics Tool ##.gpj    

6. Select the following tables to import and click OK. 

 

ROCK_MECH_MATERIAL_CLASS and ROCK_MECH_MATERIAL_CLASS_ZONES are required; the other 
tables displayed above are used by the example classification.  Your project file will need a 
table equivalent to GEOLOGY_PROJECT_UNIT, and you may find it convenient to import it. 

Other tables and fields in Rock Mechanics Tool ##.gpj are provided as examples, and 

don’t need to be merged into your project file and you may already have similar table in your 
project file. 

7. Select POINT Table from the yellow drop down list. 

8. Select Tables > Merge Fields from Other Files... then browse the installation CD and select 

the file Rock Mechanics Tool ##.gpj    

Click Open. 

9. Select POINT and click OK. 

10. Select Material_Classification_ID and click OK. 

 

You may like to move Material_Classification_ID towords the top of the POINT table field list box. 

11. Click Save. 

1.7 Initial Configuration 

Following the library and project merge steps, the following items may be optionally configured: 

1.7.1 Import example Rock Classification schema 

1. Select File > Open Project … and open the project file that you merged the tables and fields 
into. 

2. Select File > Open File > Current Project to open your current project file. 

3. Select File > Import/Export > Import from Database. 
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4. Select the Launch Windows Explorer button on the right hand side of the Database line and 

then browse the installation CD and select the file Rock Mechanics Tool ##.gpj  

  

5. Select the Browse button on the right hand side of the Select Tables line.   

6. Select ROCK_MECH_MATERIAL_CLASS and ROCK_MECH_MATERIAL_CLASS_ZONES 
Tables from the list and click OK. 

  

7. When the following window appears, click OK. 

  

8. Take care to read the Overwrite Options dialog and change it to Records if you wish to 
overwrite the file, ELSE check that it is set to Never. 
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9. Click OK to finish the import. 

1.7.2 Reordering the Group and Field input sequence. 

Once you have merged the Tables and Fields and have imported the example classification schema, 
you may wish to re-order the sequence in which they Groups and Tables appear within your database. 
This can be easily done on as follows: 

1. Select INPUT. 

2. Select Tables > Group Sequence to open the Group Sequence list in your current project file. 

3. Reorder the Groups as required. 

4. Select the Main Group tab, and Point table 

5. Select Material Classification ID field and then drag the column position to the desired 
position in your current project file. 

6. Select Tables > Import Multiple Tables... then browse the installation CD and select the file 
Rock Mechanics Tool ##.gpj    

7. Once you have made the required changes then update you data template file by selecting 
Tools > Make Data Template... and either create a new data template or over write an 
existing one, thus ensuring that your data template has the new tables and fields. 

   

 

1.8 Activate License 

After installation (and before using the Rock Mechanics Tool Add-in), activate the user license as 
described in Chapter 3 of the Datgel Product Licensing System User Guide. 

Note: You only need to activate this product when you run the Datgel Rock Mechanics Tool in gINT 8 for the 

first time. 
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2 Project Tables 

2.1 POINT 

The Material Classification ID field is used to set the Rock Mechanics Material Classification schema that is 
to be used for each PointID. The material classification schemes are stored in the Rock Mechanics 
Tool Group Tab in the individual project database files. The user can configure a particular scheme 
based on a maximum of three parameters. Once defined, a classification can then be assigned to a 
PointID on the POINT table. 

  

2.2 ROCK_MECH_MATERIALS_CLASS 

This table is used to define the each of the Classifications and the table and field names associated 
with each parameter. Each classification has a unique name that is then use on the POINT table. 
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2.3 ROCK_MECH_MATERIAL_CLASS_ZONES 

This table is stores the individual values for each parameter that is used by the Datgel Rock Mechanics 
Tool to determine the material classification zone for each PointID. 
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3 Setting up the Tool 

3.1 Defining a Rock Mechanics Material Classification 

3.1.1 ROCK_MECH_MATERIAL_CLASS Table 

In the Datgel Rock Mechanics Tool Group Tab, define a Classification ID and a Description for the material 
classification on the ROCK_MECH_MATERIAL_CLASS table. Next you must define each of the parameter 
types that you will want to evaluate your data against.  

Table 1 – Definition of ROCK_MECH_MATERIAL_CLASS Parameters 

Field Name Explanation 

Parameter # Table Enter the project database table name (not the caption name) storing the 
parameter information 

Parameter # Bottom Field If the table has a bottom depth field, enter the database field name  

Parameter # Minimum Value Field Enter the database field name that contains the minimum criteria data. If there 
is only one criteria, then define the database field name as the minimum 

Parameter # Maximum Value Field Enter the database field name that contains the maximum criteria data. If no 
maximum exists then leave this field blank 

Parameter # Range Option Select the most appropriate option for the range from the look up list (see 
Table 2) 

Parameter # Lookup Order If the database minimum and maximum fields used in the definition are looked 
up from a library table and that library table has a field to define the order of the 
data, then you can specify the name of the library table field here  

If your parameter is a term like rock strength, e.g. EL or VH, then the lookup must be a library or project 
table, and must have an Order field.  The order field would normally be an integer or double type, and 
be populated for each row of the lookup table. 

Table 2 – Parameter Range Options 

Range Option Description of Range Option 

Single Only minimum field name is defined and will be used (default) 

Minimum Use minimum, if minimum is empty then use maximum 

Maximum Use maximum, if maximum is empty then use minimum 

Average Average of minimum and maximum (or one if the other is empty) 

Both Test both minimum and maximum fit is zone 
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Following is an example of a Classification ID that has been defined with 3 parameters: 

Table 3 – Example of ROCK_MECH_MATERIAL_CLASS Parameters 

Field Name Example Entity provided Explanation 

Parameter 1 Table GEOL The criteria data for Parameter 1 is stored in the 
GEOL table 

Parameter 1 Bottom Field GEOL_BASE This is the bottom depth field for Parameter 1 

Parameter 1 Minimum Value Field GEOL_LEG The primary graphic is being used as the 
minimum (and only) assessment criteria for 
Parameter 1 

Parameter 1 Maximum Value Field  This has been left blank as there is only one 
criteria being assessed for Parameter 1 

Parameter 1 Range Option Single Only one criteria is being used so the range 
option is defined as single  

Parameter 1 Lookup Order  This has been left blank as there is no order 

Parameter 2 Table RCKS The criteria data for Parameter 2 is stored in the 
RCKS table 

Parameter 2 Bottom Field RCKS_BASE This is the bottom depth field for Parameter 2 

Parameter 2 Minimum Value Field RCKS_STRN The minimum rock strength is being used as the 
minimum assessment criteria for Parameter 2 

Parameter 2 Maximum Value Field RCKS_STRX The maximum rock strength is being used as the 
maximum assessment criteria for Parameter2 

Parameter 2 Range Option Both Both the minimum and maximum values are 
used to check that the data in the Parameter 2 
fields fall within the minimum and maximum 
defined values  

Parameter 2 Lookup Order Order The library table that stores the abbreviation 
code used to describe the minimum and 
maximum rock strengths also contains a field 
called ORDER which is used to sort the 
minimum and maximum values 

Parameter 3 Table FRAC The criteria data for Parameter 3 is stored in the 
FRAC table 

Parameter 3 Bottom Field FRAC_BASE This is the bottom depth field for Parameter 3 

Parameter 3 Minimum Value Field FRAC_IMIN The minimum fracture spacing is being used as 
the minimum assessment criteria for Parameter 
3 

Parameter 3 Maximum Value Field FRAC_IMAX The maximum fracture spacing is being used as 
the maximum assessment criteria for Parameter 
3 

Parameter 3 Range Option Average The average value from the minimum and 
maximum Parameter 3 fields is required for this 
assessment 

Parameter 3 Lookup Order   This has been left blank as there is no order 

 

Once you have defined the required Parameters, you must then also define the target where the 
material classification will be written to.  
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In the following example, the material classification is defined to be written to the 
GEOLOGY_PROJECT_UNIT_2 table. 

Table 4 – Example of ROCK_MECH_MATERIAL_CLASS Target Table Specification 

Field Name Example Entity provided Explanation 

Target Table GEOLOGY_PROJECT_UNIT_2 Enter the database table name (not the 
caption name) where you want to write 
the material classification to 

Target Bottom Field GEOL_BASE If the table that you want to write the 
material classification to has a bottom 
depth field, enter the database field 
name 

Target Zone ID Field  Database field that stored the Zone ID.  
In the example the Zone ID is not of 
interest, and hence this is left empty. 

Target Name Field GEOL_GEO2 Enter the database field name that you 
want to write the material classification 
to 

Target Description Field  Database field that stored the long 
description.  In the example the 
Description is not of interest, and hence 
this is left empty. 

 

3.1.2 ROCK_MECH_MATERIAL_CLASS_ZONES Table 

In the Datgel Rock Mechanics Tool Group Tab, define a Zone ID and a Name for the material 
classification on the ROCK_MECH_MATERIAL_CLASS_ZONES table. Next you must define each of the 
parameter values that you will want to evaluate your zones against.  

Table 5 – Definition of ROCK_MECH_MATERIAL_CLASS_ZONES Parameters 

Field Name Explanation 

Parameter # Minimum Sign Pick the minimum sign that is associated with the parameter value (see Table 
6) 

Parameter # Minimum Value Enter the minimum value associated with the parameter   

Parameter # Maximum Sign Pick the maximum sign that is associated with the parameter value (see Table 
6). If no maximum exists then leave this field blank 

Parameter # Maximum Value Enter the maximum value associated with the parameter. If no maximum exists 
then leave this field blank 

 

Table 6 – Parameter Sign Values 

Range Option Description of Range Option 

< Less than 

<= Less than or equal to 

<> Not equal to 

= Equal to 

> Greater than 

Like Like comparison 

Not Like Not like comparison 
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Note: Comparisons are NOT case sensitive; stings are converted to upper case and then compared. 

The Like and Not Like comparisons accept the same syntax as the gINT Software Like (function) 
defined in the gINT on Line Help. 

Following is an example of 1 Classification Zone that has been defined with 3 parameters: 

Table 7 – Example of ROCK_MECH_MATERIAL_CLASS_ZONES Parameters 

Field Name Example Entity provided Explanation 

Zone ID Z01  

Name Siltstone – Scraper  

Description Material can be easily 
removed using a scraper 

 

Parameter 1 Minimum Sign = The value in the GEOL_LEG field in the 
database must be equal to SILTSTONE Parameter 1 Minimum Value SILTSTONE 

Parameter 1 Maximum Sign  These have been left blank as there is only 
one criteria being assessed for Parameter 1 Parameter 1 Maximum Value  

Parameter 2 Minimum Sign >= The value in the RCKS_STRN field in the 
database must be greater than or equal to EL Parameter 2 Minimum Value EL 

Parameter 2 Maximum Sign <= The value in the RCKS_STRX field in the 
database must be less than or equal to VL Parameter 2 Maximum Value VL 

Parameter 3 Minimum Sign >= The value in the FRAC_IMIN  field in the 
database must be greater than or equal to 0 Parameter 3 Minimum Value 0 

Parameter 3 Maximum Sign < The value in the FRAC_IMAX field in the 
database must be less than 300 Parameter 3 Maximum Value 300 

To complete the classification, each Zone that is required must be specified, as indicated in the 
following example: 
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3.1.3 Example using Not Like 

This example refers to the Grain size field on the Rock Stratum description table (GORA) in the AGS 
RTA database.   

 

3.1.3.1 ROCK_MECH_MATERIAL_CLASS Table 
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3.1.3.2 ROCK_MECH_MATERIAL_CLASS_ZONES Table 
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4 Using the Tool 
Once you have defined a Rock Material Classification Scheme, a defined classification can then be 
assigned to each PointID on the POINT table.  

1. Select INPUT and go to the HOLE/POINT table 

2. In the Material Classification ID field, select the Rock Material Classification that you have 
previously defined in the ROCK_MECH_MATERIAL_CLASS and 
ROCK_MECH_MATERIAL_CLASS_ZONES tables 

 

3. Select Add-Ins > Datgel Rock Mechanics Tool   

4. To determine the material classification for a selected PointID, choose the Material 
Classification Tool – Current PointID. 

5. To determine the material classification for all PointIDs, choose the Material Classification 
Tool – All PointIDs. 

The Tool will then run and write the material classification to the target table as defined for that 
classification scheme.  On completion, the Tool will also provide you with a full report (see 
example below). 
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