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About Datgel Photo Tool 3 
The Datgel Photo Tool gINT Add-In makes it quick and easy to link, organise and print core box photos, 
test pit photos, surface photos, sketches and more in gINT.  

The photos are recorded in a table in gINT and sorted by depth or image number. Metadata such as 
date taken and description are also retrieved automatically. Included with the Photo Tool are graphic 
table and log reports, which can output your photos, grouped by PointID, ordered by depth or image 
number, and layouts of 1, 2 or 4 photos per page are available. 

You need to complete the installation procedure (see Installation & Licensing on page 1) and activate 
(see Datgel Product Licensing System User Guide) before you can use the Photo Tool. 

New in Version 3 (May 2011) 

1. Tool now supports gINT Professional Plus SQL Server databases, as well as Access 
databases 

2. New field to support SQL Server: PROJECT.Parent_Initial_Image_Folder; Optional for Access, 
required for SQL Server. Stores the parent folder/directory path containing the sub-folders of 
images 

3. Reports now accept Image Number with Alphanumeric strings, and will order photos 

4. File naming validation reported when linking images, including: 

 File extension 

 Non-existent PointIDs 

 Depth > Bottom 

 Depth or Bottom > Hole Depth 

5. User definable order of Image Types in combo box on Photo Tool form 

6. Library reporting code optimised and reorganised 

New in Version 2 (June 2009) 

1. Description text configuration, to allow the user full control over what identification and 
description information displays below the photos on reports. 

2. New images types 

3. Title block on Graphic Table reports, making the reports instantly usable and presentable. 

4. Example log showing images by depth, which allows you to copy the example of a downhole 
image into your existing gINT log report. 

5. More graphic table reports for samples and vibrocores 

6. Hardware Key licensing with Single User and Network options 

7. Improved documentation 

Support 

12 months support and maintenance is included with the license purchase.  For technical support 
please email support@datgel.com or call +61 2 8202 8600. 

Note: Please check that you have named the files and folder correctly (as described in section 2.1) 
before contacting us. 

mailto:support@datgel.com
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System Requirements 

gINT 

The product runs optimally using gINT 8.3 or higher, however it will run using gINT 8.1 or higher.  

gINT Professional or gINT Professional Plus is required since the tool uses Graphic Table reports. 

Photo Tool version 3 is designed for use with a gINT SQL Server database or Access database 

Hardware and Operating System 

Same system requirements as gINT 8.3, see: http://www.gintsoftware.com/products_requirements.html. 

Required Windows Components 

1. Windows Installer 3.1 

2. .NET 3.5 Framework SP1 

Conventions and typography used in this guide 

Note: Tips and additional Information to help you. 

> Used to indicate a series of menu commands. 

e.g. Select File > Open.  

| Used to indicate a gINT Application Group, Application, Table Group or Table , e.g. 
DATA DESIGN | Project Database 

Bold Text Items you must select, command buttons, or items in a list. 

e.g. Navigate to UTILITIES | Convert Projects (4
th

 tab). 

Italics Emphasis Use to emphasize the importance of a point such as parameters. 

e.g. Data Entry – Check Omit Must Save prompt when save is required 

CAPITALS Names of keys on the keyboard. for example, SHIFT, CTRL, or ALT. 

KEY+KEY Key combinations, for example CTRL+P, or ALT+F4. 

Code Snippet Indicates a code snippet within a paragraph 

Code sample Indicates a sample program codes inserted in user guide e.g. 

public override string ToString () 

File name or path Used for formatting file name and paths e.g. di_lib.glb or  

V:\10 gINT\Datgel Install Files\ 

Table_Name Database table name, e.g. POINT_TABLE. 

Field_Name Database field name; e.g. PointID 

Command line Command line, presented exactly as it must be entered e.g. 

cdir 

 

http://www.gintsoftware.com/products_requirements.html
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1 Installation & Licensing 

1.1 Installation Overview 

There are four parts to the installation process: 

 Install DLL programs 

 Merge gINT library objects 

 Merge gINT project table to your project file and your data template 

 Activate the product license 

The first three steps can be performed in any order and are described below. The activation procedure 
must be done last and is described in the Datgel Product Licensing System User Guide. 

1.2 Package Contents 

Your software purchase may have come with the following contents: 

 Applications CD which normally has the following folders:  
\Datgel Photo Tool X.X.X\Documentation 

\Datgel Photo Tool X.X.X\gINT Files 

\Datgel Photo Tool X.X.X\Installation files 

\Datgel Network License Server 

 A hardware license key 

1.3 Before Installation 

A few basic preparations can help ensure an effortless installation. 

 Make sure that the computer where you plan to install the program meets the minimum system 
requirements.  

 Connect your PC to Internet before installation (must have a working Internet connection).  

The Photo Tool requires that the Windows Installer 3.1 and Microsoft .net 3.5 framework SP1 
is installed on the PC prior to the installation of the Tool.  If your PC does not have these 
installed, then they will be automatically downloaded and installed during the Tool installation 
process.  

 Log into the PC with Administrator privileges before starting installation. 

 It is recommended that you exit out of other applications that maybe running on your PC. 

 Close gINT before you start installation. 

 Keep the serial number and license number handy. 

1.4 Install DLL Programs  

3. If you are upgrading from version 2.XX, follow these steps as well. 

4. If you received an installation CD, then insert the CD and browse to the folder  
\Datgel Photo Tool X.X.X\Installation Files\Setup.exe 

5. Double click the file named Setup.exe 

6. Click Run to begin installation. 

Follow the on screen instructions when installation begins: 
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7. Click Next on the Welcome to the Datgel Photo Tool Setup dialog. 

 

8. Scroll and carefully read the License Agreement, and choose option I Agree, and click Next. 

 

Alternatively choose I Do Not Agree and click Cancel if you disagree with the license 
agreement. The installation will stop and exit.  

9. On the Select Installation Folder dialog, either accept the default folder (recommended) or 
select Browse to specify the folder where you want to install the Photo Tool Add-In. 

Leave Everyone bulleted to indicate that anyone logged onto the PC can use the Photo Tool 
Add-In. 

Click Next when ready. 
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Optional: Click on Disk Cost to view the disk space statistics. Click OK when done. 

 

10. Click Next to start installation. 

 

11. Observe the progress bar to monitor installation progress.  
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12. Click Close when the Installation Complete dialog is displayed. 

 

1.5 Merge gINT Library Objects 

 IMPORTANT   In the trial version of the Photo Tool, the library will be locked and you cannot merge 

any gINT Library Objects into your Library file, or make changes to this Library file.  In this case, you 
have to use the locked library as-is.   

If you have purchased the Photo Tool, then you have full access to the library objects, and you may 
proceed with the following steps to merge the gINT Library components into your Library file.  

1. Make a backup copy of your existing library file. By default this is located in: 

C:\Users\Public\Documents\Bentley\gINT\libraries  

Or 

C:\Program Files\gINT\Bentley\Libraries\ 
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2. Open Windows Explorer and copy the gINT Files folder from the installation CD to your 

Desktop. 

3. Start gINT and open the library and project file you wish to use with Datgel Photo Tool. 

The opened project and library files are displayed at the top of the gINT Window. 

 

4. Select UTILITIES | Lib Merge/Copy. 

 

5. Check the bullet that reads Merge from. 

6. In the Source Library File pane, browse to the gINT Files folder (that you previously copied 

from the installation CD to your Desktop) for the file  

Datgel Photo tool <DGD or AGS RTA> ## lib.glb where ## is the version number. 

 IMPORTANT   If you are currently using an AGS RTA type database you should select the 

Datgel Photo tool AGS RTA ## lib.glb as the Source Library File. If you are not 

using an AGS RTA type database you can chose either library file, however we would 
recommend DGD.  

 

 IMPORTANT   Make a note of which source library file you merge as you will need this 

information in Section 1.6 

7. Check the bullet that reads Select All. 

8. Check the bullet that reads Query on Overwrite. 
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9. Click  button to move all tables from the Available Source Tables pane on the left to the 
Tables to Merge/Copy pane on the right side. 

10. Click Execute. 

Take care to read the overwrite dialog and click Yes if you wish to overwrite the file, ELSE click 
No. 

 

This will merge in the Add-In menu item, Image Type lookup list, gINT Rules modules, graphic 
tables, log reports and user system data, which are all related to the Tool. 

11. Click OK to finish the merge. 

 

1.6 Merge gINT Project Table 

1. Make a backup copy of your existing project file. By default this is located in: 

C:\Users\Public\Documents\Bentley\gINT\Projects\ 

Or 

C:\Program Files\Bentley\gINT\Projects\ 

2. Start gINT and open the library and project file you wish to use with Datgel Photo Tool. 

3. Select DATA DESIGN | Project Database. 

 OPTIONAL  If you get the message Use the File menu to select or create a database, then 

select File > Open File > Open Project, browse to the location you have your project file 

(.gpj) stored at, click on the project file name, and click Open. 

4. Select File > Open File > Current Project… to open your current project file. 

5. Select Tables > Merge all Tables and Fields...  then browse to the gINT Files folder (that 

you previously copied from the installation CD to your Desktop) and select the file 

 Datgel Photo Tool <DGD or AGS RTA> ##.gpj where ## is the version number. 

 IMPORTANT   If you are currently using an AGS RTA type database you must select the 

Datgel Photo tool AGS RTA ##.gpj as the Source Database File.  

If you previously merged the Datgel Photo tool AGS RTA ## lib.glb in Section 1.5, 

you must use the Datgel Photo tool AGS RTA ##.gpj as the Source Database File.  

If you previously merged the Datgel Photo tool DGD ## lib.glb in Section 1.5, you 

must use the Datgel Photo tool DGD ##.gpj as the Source Database File.   

Click Open. 
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6. Change to the PROJECT table, and review/delete fields.  Ensure Parent_Initial_Image_Folder is 
retained. 

7. Select INPUT | Main Group to review the new IMAGE and IMAGE_DESCRIPTION table. The order 
in which the Image and Image Description tab appears in gINT INPUT can be changed in the 
Tables > Input Sequence… menu option.  We suggest IMAGE comes before 
IMAGE_DESCRIPTION. 

 

8. In the IMAGE_DESCRIPTION table is empty, import data from Datgel Photo Tool <DGD or 

AGS RTA> ##.gpj for this table only. 

9. Select Tools > Make Data Template to either create a new data template, or write over an 
existing one to ensure your data template has the new table.  

 

10. Click Save when finished. 

11. Once you have completed the above steps you can now delete the gINT Files folder that 

you previously copied onto your Desktop. 

1.7 Validate or Activate License 

After installation (and before using the Photo Tool Add-in), validate or activate the user license as 
described in Chapter 2 of the Datgel Product Licensing System User Guide. 

1.8 Upgrading from Version 1 or 2 

1. Installed the new DLL program, by running the setup.exe file.  There is no need to uninstall the 
old version. 

2. Make a backup of your library and project/data template. 
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3. Go to DATA DESIGN | Library Tables, and delete the table DG_PHOTO_IMAGE_TYPE.  Or if you 
prefer, add a field named Order with an Integer Type, and then populated the field in Library 
Data with the desired order as described in section 2.3. 

4. Merge all library objects, and the project table, as described in the steps 1.5 & 1.6 above. Note 
this will overwrite existing reports. 
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2 Using the Tool 

2.1 Linking the images to the database 

1. Start gINT and open the library and project file you wish to use with Datgel Photo Tool. 

2. Click INPUT. 

3. Select Add-Ins > Datgel Photo Tool > Datgel Photo Tool to launch the add-in. 

 

4. On the Datgel Photo Tool dialog, browse to the folder where the images are located. 

 

 Folder: Folder containing the photos to be linked to the gINT project. 

 Image Type: Type of image in the folder.  This will be written to the project database 
Image_Type field. 

 Parent/Initial Image Folder: Optional for Access, required for SQL Server. Stores the 
parent folder/directory path containing the sub-folders of images.  A \ at the end is not 
required.  Hence you can store the photos folders in a different folder to the gINT project 
file, but you must provide the path of the parent folder to allow the photos to be output. 

5. In the Image type drop down list, select the image type, and click Ok to import the photo file 
information into the Image table. Once the image file information has been imported, the 
photos can be outputted onto the Graphic Table reports.  

The file names must follow the format described in the above screenshot.  

The file naming format for all photo image types is  

<PointID>_<Depth>-<Bottom depth>.<jpg or bmp> OR  
<PointID>[_<image number>].<jpg or bmp> 

Either format is acceptable. 
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If Parent/Initial Image Folder is empty, the image files must be placed in a folder with a 
specified name, and the folder must be placed in the same directory as the project file.   

Alternatively, if the Parent/Initial Image Folder is set, the image files must be placed in a 
folder with a specified name, and the folder must be placed in the Parent/Initial Image Folder. 

The table below explains the folder naming format.   

The photo import form can accept depth and bottom depth formats “00.00” or “000.00” for 
photos e.g. 03.34 and 17.40 or 108.00 and 021.53.  However, the Graphic Reports can only 
handle one format only.  The format which the Graphic Reports can handle can be configured 
in DATA DESIGN > User System Data tab, select DG Photo Depth Num Dec from the yellow 
drop down pick list, and modify the format. 

 

Table 1   Folder Naming Format 

Image Code Description Folder Name 

CPB Photo of a core box <Project file name or Project Unique ID> core photo 

CPC Photo of a core length <Project file name or Project Unique ID> core photo column 

DIC Downhole Image  <Project file name or Project Unique ID> downhole image column 

FS Sketch of a test pit face, exposure 
or traverse 

<Project file name or Project Unique ID> field sketch 

SP General surface photo <Project file name or Project Unique ID> photo 

SS General surface sketch <Project file name or Project Unique ID> photo 

SSP Sample Photo <Project file name or Project Unique ID> sample photo 

TRP Test pit, exposure or traverse 
photo 

<Project file name or Project Unique ID> photo 

VCP Vibrocore Photo <Project file name or Project Unique ID> vibrocore photo 

VSC Sketch of core length <Project file name or Project Unique ID> visual column 
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An example of the folder and file naming formats are shown below.  In this example the project 

file name is Datgel photo tool AGS RTA 1_7.gpj.   

If an SQL Server database is used, the Project Unique ID is used in place of the gINT Project 
file name for folder names.  The Project Unique ID is the number/code listed on the PROJECT 
table. 

 

 

 

 

 

 

6. When you have selected the folder with the images, click Ok.  The tool will now update the 
database. 

Overwrite problems and file naming validation will be reported.  Validation test include: 

 File extension 

 Non-existent PointIDs 

 Depth > Bottom 

 Depth or Bottom > Hole Depth 

7. You may run the tool numerous times.  When ready, click Exit to return to gINT INPUT. 

8. Select INPUT | Main Group | Image to check the fields have been populated.  

Check that you have the corresponding PointID selected.  

If you had the image tab opened prior to using the tool, you should instantly see the new 
records. 
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2.2 Configuring the Description Text 

The description text that appears below each photo in the Graphic Table reports is configurable.  The 
description text is built up of up to four description entities, and a prefix and suffix for each description 
entity.  The description entity, prefix and suffix may refer to data in fields from the IMAGE table or may 
simply be a word or character.  Each image type may have a particular description set. 

The description (root), prefix and suffix entities to display under each photo on the Graphic Table 
reports are set in the IMAGE_DESCRIPTION table. 

 

There are four description entities, depicted in the fields Description_1, Description_2, Description_3 and 
Description_4. Each Description fields have a field for the prefix and suffix, and are named 
Description_1_Prefix, Description_1_Suffix and so on.  Each of these fields has a pick list, where you can 
choose the appropriate prefix, description and suffix entities for each image type. The entities will print 
in ascending order, left to right so for example, Description_1 will print before Description_2. 

Note that the prefix and suffix will only print if the corresponding description returns a value. 

The pick list values come from the library table DG_PHOTO_IMAGE_DESCRIPTION. The most common 
types of descriptions, prefixes and suffixes are provided, but you can create your own or modify any of 
the existing ones in this table. 
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Note: Knowledge of the SQL language may be required to configure the DG_PHOTO_IMAGE_DESCRIPTION 
table. 

The DG_PHOTO_IMAGE_DESCRIPTION table has three fields of importance – Description, SQL_Field_Expression 
and Expression_Type. 

 

The Description field is the name of the description, prefix or suffix as it will appear on the 
IMAGE_DESCRIPTION table and in the drop down list for each of the fields.  The remark field may be used 
to clarify the description entity and will appear in the 2

nd
 column in the drop down list in the 

IMAGE_DESCRIPTION table. 

The SQL Field Expression field is where the expression to print the description, prefix or suffix is 
entered.  Each expression as entered in the IMAGE_DESCRIPTION table is concatenated with a “ & ” for 
each Image Type and inserted into the SELECT statement of an SQL query that builds the description 
text for each photo on output.  

Therefore, the values entered in the SQL Field Expression field must form a valid SQL SELECT 
statement, or else the entire description text will fail to print.  The Table and Field Data Tool can be 
used to insert Table/Field references.  To insert the table/field reference formatted to the SQL format 
[Table].[Field], right-click on the Paste button after selecting the table and field from the drop down pick 
lists. 

The Expression_Type field is used to control what rows will appear in lookup lists of fields in the 
IMAGE_DESCRIPTION table.  The three choices available are Prefix, Root and Suffix, and the fields in the 
IMAGE_DESCRIPTION table will filter the rows in the DG_IMAGE_DESCRIPTION library table depending on 
the value in the Expression Type.  

So for example, in the IMAGE_DESCRIPTION table, the Description_X_Prefix fields will only show the rows in 
the DG_IMAGE_DESCRIPTION library table with “Prefix” as the Expression Type, the Description_X fields will 
only show rows with “Root” as the Expression Type, and the Description_X_Suffix fields will only show rows 
with “Suffix” as the Expression Type. 

Note that if the Expression Type is “Root”, the SQL Query builder will check if the SQL Query 
Expression will return a value first to determine whether or not to include the prefix and suffix 
expressions for that description entity. This applies for each individual photo description. 



 

 

Photo Tool gINT Add-In 3 –  Datgel 
User Guide 14 DPT-UG-001 - 3.02 - June 2011 
 

2.3 Configure Image Type Combo Box Order 

The order of items in the Image Type combo box on the Photo Tool form may be defined in DATA 
DESIGN | Library Data | DG_PHOTO_IMAGE_TYPE.  Set the Order field values. 

 

2.4 Output the Images 

The following log and graphic table reports are available with the Photo Tool Add-In. 

Table 2   Log Reports 

Report Name Description 

DG PHOTO TEST PIT NO SKETCH LOG Example test pit log with photos printing on additional 
pages.  Reports photos listed on the Image table with type 
FS, SP, SS and TRP.  Files must be located in <path to 
project>\<Project file name> Photo\.  Files must be named 
<PointID>_<Image Number>.<jpg or bmp>. 

DG PHOTO TEST PIT WITH SKETCH LOG Example test pit log with photos printing on bottom half of 
page and on additional pages.  Reports photos listed on 
the Image table with type FS, SP, SS and TRP.  Files must 
be located in <path to project>\<Project file name> Photo\.  
Files must be named <PointID>_<Image Number>.<jpg or 
bmp>. 

DG PHOTO VISUAL COLUMN LOG AND CORE BOX 
LOG 

Photo Visual Column Log with options to display image 
types CPC, DIC and VSC. The field POINT.Visual_Column 
controls which images type display. Core box photos print 
on additional pages. 

The log reports are provided as examples, and we expect users to copy and use the objects on their 
existing custom log reports. 
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Table 3   Graphic Table Reports 

Report Name Description 

DG PHOTO CORE PHOTO 1 PER PAGE Reports photos listed in the Image table with type CPB 
specified in the Images table. Displays 1 photo per page, 
size A4, landscape orientation. 

DG PHOTO CORE PHOTO 2 PER PAGE Reports photos listed in the Image table with type CPB 
specified in the Images table. Displays 2 photos per page, 
size A4, Portrait orientation. 

DG PHOTO CORE PHOTO 4 PER PAGE Reports photos listed in the Image table with type CPB 
specified in the Images table. Displays 4 photos per page, 
size A4, Portrait orientation. 

DG PHOTO SAMPLE PHOTO 1 PER PAGE Reports photos listed in the Image table with type SSP 
specified in the Image table. Displays 1 image per page, 
size A4, Landscape orientation. 

DG PHOTO SAMPLE PHOTO 2 PER PAGE Reports photos listed in the Image table with type SSP 
specified in the Image table. Displays 2 image per page, 
size A4, Portrait orientation. 

DG PHOTO TEST PIT PHOTO 1 PER PAGE Reports photos listed in the Image table with type FS, SP, 
SS and TRP specified in the Images table. Displays 1 
photo per page, size A4, Portrait orientation. 

DG PHOTO TEST PIT PHOTO 2 PER PAGE Reports photos listed in the Image table with type FS, SP, 
SS and TRP specified in the Images table. Displays 2 
photos per page, size A4, Portrait orientation. 

DG PHOTO VIBROCORE PHOTO 1 PER PAGE Reports photos listed in the Image table with type VCP 
specified in the Image table. Displays 1 photo per page, 
size A4, Landscape orientation. 

DG PHOTO VIBROCORE PHOTO 2 PER PAGE Reports photos listed in the Image table with type VCP 
specified in the Image table. Displays 2 photos per page, 
size A4, Portrait orientation. 

The graphic table reports have a standard title block in the form of a Drawing Library entity, and the 
user may modify or create the title block for the reports in the DRAWINGS | Drawing library tab. It is 
important that the existing entities on the report are not deleted, as they are all required for the reports 
to function correctly. 

1. Start gINT and open the library and project file you wish to use with Datgel Photo Tool. 

2. Select OUTPUT | Graphic Tables or OUTPUT | Logs 

3. Select a report from the top down list as required, then select the PointID, and click Preview

, Print  button, or Export. 
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The following is an example of a core photo, 4 per page in preview mode. 

  

The following is an example of a test pit photo, 2 per page in preview mode. 
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